
© 2024 GRi Simulations Inc. All Rights Reserved.

M-500-013

iDEA-DT User Manual

Restriction on Use, Publication, or Disclosure of Proprietary Information
This document contains information proprietary to GRi SIMULATIONS INC., to its subsidiaries or to a third party to w hom GRi

SIMULATIONS INC. may have a legal obligation to protect such information from unauthorized disclosure, use or duplication. Any
disclosure, use or duplication of this document, or of  any of the information contained herein, for other than the specif ic purpose for

w hich it w as disclosed is expressly prohibited, except as GRi SIMULATIONS INC. may otherw ise agree to in w riting.



   

iDEA-DT User Manual 2

Table of Contents

1. Introduction ........................................................................................................................................ 3
1.1 System Requirements ................................................................................................................. 4
1.2 Quick Start Guide ........................................................................................................................ 5
1.3 Definitions ................................................................................................................................... 6
1.4 Restriction of Use ........................................................................................................................ 7

2. iDEA-DT User Interface ....................................................................................................................... 8
2.1 Title Bar ...................................................................................................................................... 9
2.2 MenuBar ................................................................................................................................... 10

2.2.1 File Menu .......................................................................................................................... 10
2.2.2 Mode Menu ....................................................................................................................... 12
2.2.3 View Menu ........................................................................................................................ 13

2.2.3.1 Command Dialog ........................................................................................................ 14
2.2.4 Controls Menu ................................................................................................................... 17
2.2.5 Edit Menu ......................................................................................................................... 18
2.2.6 Simulator Menu ................................................................................................................. 18
2.2.7 Help Menu ......................................................................................................................... 18

2.3 Tool Ribbon ............................................................................................................................... 19
2.3.1 Select Tool ........................................................................................................................ 19
2.3.2 Measure Tool ..................................................................................................................... 19
2.3.3 Move Tool .......................................................................................................................... 20
2.3.4 Rotate Tool ........................................................................................................................ 21
2.3.5 Line Tool ........................................................................................................................... 22
2.3.6 Scenario and Replay Tools ................................................................................................. 24
2.3.7 Information and Editing Tools .............................................................................................. 25
2.3.8 Explorer ............................................................................................................................ 26
2.3.9 Info ................................................................................................................................... 27
2.3.10 Asset Library ................................................................................................................... 27

2.3.10.1 Snap Points ............................................................................................................. 27
2.3.11 Properties Panel .............................................................................................................. 28
2.3.12 Browser ........................................................................................................................... 28
2.3.13 Aerial Camera Settings ..................................................................................................... 29

2.4 Viewport ................................................................................................................................... 31
2.4.1 Aerial View ........................................................................................................................ 33
2.4.2 Map / NAV Views .............................................................................................................. 34
2.4.3 Objective Overlay ............................................................................................................... 36

2.5 Status Bar ................................................................................................................................ 38
3. How to / Tutorials ............................................................................................................................. 39

3.1 Import a Terrain ......................................................................................................................... 40
3.2 Create / Edit a Scenario ............................................................................................................. 42
3.3 Create / Edit a Line .................................................................................................................... 43
3.4 Create / Edit a Jumper ............................................................................................................... 45
3.5 Create / Edit a Group ................................................................................................................. 47
3.6 Working with GIS Data ............................................................................................................... 50

4. Keyboard Commands ....................................................................................................................... 52
5. Troubleshooting ................................................................................................................................ 53



   

iDEA-DT User Manual 3

1 Introduction

Welcome!

This document is intended to provide a full reference for the operation of the iDEA-DT (interactive Design,
Engineering and Analysis – Digital Twin) application developed by GRI Simulations Inc.

If you have questions about a topic that is not covered in this document, please visit our web support for
assistance.

http://grisim.kayako.com/
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1.1 System Requirements

To run the iDEA-DT, you will need:

System Element Minimum Requirement
Operating System Windows 10
Processor i7
RAM 8 GB
Graphics Card GeForce RTX 2060
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1.2 Quick Start Guide

Software installation:

1. Run the provided installer to install the iDEA-DT software.
§ This will install all software and drivers required to run the iDEA-DT.

To quickly start and edit an existing VROV scenario:

1. Double-click the  (iDEA-DT icon) on the Desktop.
2. Select File > Open Scenario from the MenuBar to open the Select Scenario dialog.
3. Choose a scenario from the dropdown and click OK to start the scenario in Editor mode.
4. To modify the scenario, select Mode > Editor from the MenuBar, then use the Tool Ribbon and/or

Asset Library to edit the scenario. 
§ Save modifications by selecting File > Save Scenario As.

· Please see notes on scenario names.

· Note that it is recommended to always use a different name from any of the
existing content so there is no confusion between existing and custom content.

5. To start dynamic simulation, select Mode > Simulator from the MenuBar.

To quickly start building a new VROV scenario:

1. Double-click the  (iDEA-DT icon) on the Desktop.
2. Select File > New from the MenuBar to open the Select Terrain dialog.
3. Choose an existing terrain from the dropdown and click OK to start a new scenario with the

selected terrain in Editor mode.
4. Objects can be added to the scenario from the Asset Library.

§ From the library, either double-click the desired object or drag it from the library into the 
Viewport

5. When the scenario is complete, save it by selecting File > Save Scenario or File > Save
Scenario As.
§ Please see notes on scenario names.
§ Note that it is recommended to always use a different name from any of the existing

content so there is no confusion between that and any custom content.
6. To start dynamic simulation, select Mode > Simulator from the MenuBar.

To copy all custom scenarios from the iDEA-DT to the VROV Simulator:

1. Double-click the  (iDEA-DT icon) on the Desktop.
2. Select Simulator > Update from the MenuBar.
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1.3 Definitions

Below are definitions for some of the terms that will be encountered in this document:

GRi Simulations Inc. (GRi)

· Developer of the iDEA (Interactive Design, Engineering and Analysis) line of software products, which
consists of 3D, interactive data visualization and simulation software tools for offshore assets, projects, and
their associated operations, providing users with a digital "sandbox" for rapid, informed investigation and
decision making.

iDEA-DT

· Interactive Design, Engineering and Analysis - Digital Twin.

· The iDEA-DT is optimized for integrating and visualizing historical and real-time data from multiple sources
in a common, interactive 3D interface.
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1.4 Restriction of Use

Restriction on Use, Publication, or Disclosure of Proprietary Information

This document contains information proprietary to GRi SIMULATIONS INC., to its subsidiaries or to a third party
to whom GRi SIMULATIONS INC. may have a legal obligation to protect such information from unauthorized
disclosure, use or duplication. Any disclosure, use or duplication of this document, or of any of the information
contained herein, for other than the specific purpose for which it was disclosed is expressly prohibited, except
as GRi SIMULATIONS INC. may otherwise agree to in writing.
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2 iDEA-DT User Interface

The iDEA-DT's user interface is similar to most Windows-based applications. The application window is divided
into 5 sections (as shown below):

Title Bar

Menu Bar

Tool Ribbon

Viewport

Status Bar
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2.1 Title Bar

The Title Bar displays the application icon, the name of the currently opened scenario, and the title of the
application on the left, as well as controls to Minimize, Maximize and Close the application window on the right.
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2.2 MenuBar

The Menu Bar displays menus which provide access to many of the iDEA-DT application's available functions.
The menu options depend on the currently selected mode.

2.2.1 File Menu

The File Menu contains functions for opening, closing, and saving files.

New

o Selecting New will start a new, empty scenario. A terrain must be selected before the new scenario
will be loaded into the Viewport. If there are multiple terrain files available, a dialog box will appear in
which the user can select the desired terrain file. If only a single terrain file is available it will be
automatically loaded into the new scenario.

Open Scenario

o Selecting Open Scenario will allow the user to open any scenario that has been saved previously
from the Select Scenario dialog.

Open Shapefile

o Selecting Open Shapefile will allow the user to create a new scenario that includes the data from
the selected GIS shapefile. Before the shapefile data can be loaded into the scenario, a terrain
must be chosen from the Select Terrain Dialog, described above. The selected terrain should be in
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the same general area as the shapefile being opened, but this is not absolutely necessary.

Open Geodatabase

o Selecting Open Geodatabase will allow the user to create a new scenario that includes the data
from the selected GIS geodatabase. Before the geodatabase data can be loaded into the scenario,
a terrain must be chosen from the Select Terrain Dialog. The selected terrain should be in the same
general area as the shapefile(s) in the geodatabase being opened, but this is not absolutely
necessary.

Open Log File

o Selecting Open Log File will allow the user to select and open any simulation log files that are
available. Log File playback will begin immediately after the scenario loads in the Viewport.

Close

o Selecting Close will close the currently loaded scenario. If changes have been made to the scenario
since it was opened, the user will be prompted to save the scenario so the changes are not lost.

Save Scenario

o Selecting Save Scenario will allow the user to save the currently loaded scenario. This function will
overwrite the last saved version of the currently loaded scenario, saving any changes that have been
made since it was opened. If the current scenario has never been saved, the user will be prompted
to enter a scenario name.

Save Scenario As

o Selecting Save Scenario As will allow the user to enter a new name for and save the currently
loaded scenario. This function is useful if the user does not want to lose the original version of the
scenario that was loaded prior to making changes.

Save Screenshot

o Selecting Save Screenshot will allow the user to capture a screenshot of the current Viewport
configuration. Before the screenshot is saved, the user will be prompted to enter the desired
resolution in the Select Resolution dialog. Users are able to capture large screenshots (much larger
than the on-screen resolution) for printing purposes, etc.
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Import Shapefile

o Selecting Import Shapefile will allow the user to browse to a directory, select a GIS shapefile, and
load the shapefile into the currently loaded scenario. 

Import Geodatabase

o Selecting Import Geodatabase will allow the user to select and import an ESRI GIS Geodatabase
file/folder into the currently loaded scenario.

Import Terrain

o Selecting Import Terrain will allow the user to import a terrain file (XYZ or TXT format) and convert it
to GRi's proprietary format. This function will add the new terrain to the list of available terrain files
in the Terrain Selection dialog.

Import Point Cloud

o Selecting Import Point Cloud will allow the user to import Point Cloud data into the scenario.

Import DWF

o Selecting Import DWF will allow the user to import a DWF file, usually containing field layout
information, into the scenario.

Export Shapefile

o Selecting Export Shapefile will allow the user to export a shapefile containing either point or line
data, reflecting the 3D models (points) and lines in the currently loaded scenarios. The user will be
prompted to select either Lines or Points as the shapefile data type prior to export.

Exit

o Selecting Exit will exit the application.  If changes have been made to the scenario since it was
opened, the user will be prompted to save the scenario so the changes are not lost.

2.2.2 Mode Menu

The Mode Menu contains options for switching the IDEA-DT between Simulator, Editor, Player, and
Visualization modes.

Simulator

o Selecting Simulator mode will enable the simulation physics, allowing any dynamic objects in the
scenario to move and interact with the environment in a realistic manner. In this mode it is possible
to control ROVs and other equipment to complete simulated operations, perform ROV accessibility
testing, and test scenarios designed for the VROV Simulator.

o There is also the option of replaying any log files recorded in this mode, as opposed to switching to 
Player mode.
§ When replaying a log file in this mode, Tool Ribbon buttons with mode-specific functions

behave as designed for Player mode.
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Editor
o In Editor mode the user is able to add or remove objects and reposition or reorient any objects in

the scenario. This mode also allows importing of GIS files and other data types.
o This is the default mode for the iDEA-DT.

Player

o Player mode allows playback of any log files recorded in Simulator mode.

Visualization

o Visualization mode allows playback of previously recorded or real-time positioning data from real-
world (non-simulated) events.

o To enable Visualization mode, ensure that RTV is selected in the View menu.
o Note that this option may not be available if the RTV plugin is not configured.

2.2.3 View Menu

The View Menu (shown below) contains functions for toggling the visibility of various User Interface elements.

Explorer

o Selecting Explorer will toggle the visibility of the Scenario Explorer.

Controls

o Selecting Controls will toggle the visibility of the VROV Simulator ICC Command Dialog for use in
Simulator Mode.

Properties

o Selecting Properties will toggle the visibility of the Properties Panel.
o This dialog displays different parameters depending on the element selected.

Browser

o Selecting Browser will toggle the web browser functionality of the iDEA-DT, showing web pages
relevant to the scenario content.

Asset Library

o Selecting Asset Library will toggle the visibility of the Asset Library.

RTV

o Selecting RTV will toggle the visibility of Real-Time Visualization components in the scenario.

Status Bar

o Selecting Status Bar will toggle the visibility of the Status Bar.
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Viewport Menus

o Selecting Viewport Menus will toggle the visibility of the Viewport/Camera Settings Menu, Object
Selection Menu, and Screen Settings Menu.

2.2.3.1 Command Dialog

The Command Dialog contains a set of controls for elements in dynamic simulations as well as a selection of
options for the simulated environment.

The Settings button ( ) provides the user options to view Aerial Camera Settings and the About information,
including links for online support, general information about GRi, or VROV licensing.

The Controls section allows the user to control movement, rotation, and the paying in/out of various elements of
a simulation. Depending on the type of object selected, some control options may be inactive (the entire section
may be hidden if the currently loaded scenario does not contain elements controllable by this feature).

Control Selection Dropdown

o A dropdown menu that displays all items controllable in the currently running scenario.

Heading Display 

o A circle with lines indicating the selected object's current and set headings.

§ The green line indicates the current heading of the selected object.
§ The blue line indicates the set heading of the object (heading selectable by clicking within

the area of the circle, or by typing into the Set Heading entry box).
o Below the circle display is the numerical value of the heading displayed in degrees.

Position Control 

o Includes an entry box (default value of 0 meters), followed by a Move button.
o To move the selected object:

1. Choose a heading at which to move the object by either:

· clicking within the area of the heading display circle,
or

· typing a heading in the Set Heading box.
2. Enter a distance (in meters) to move the object at the selected heading in the entry box.

· If a value of 0 is used, no limit will be placed on the position (the object will
continue to move until it is manually stopped).

3. Click the Move button to begin repositioning the object.

· While the object is in motion, the entry box will display the distance remaining to
the specified distance.

· While the object is in motion, the text on the Move button will change to Stop.
Motion may be stopped at any time by clicking Stop.
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Set Heading 

o Includes an entry box (default value displays the current heading of the object), followed by a Rotate
button.

o To rotate the selected object:
1. Choose a heading at which to set the object by either:

· clicking within the area of the heading display circle,
or

· typing a heading in the entry box.
2. Click the Rotate button to begin rotating the object.

· While the object is rotating, the Rotation Control entry box will display the number
of degrees remaining to the specified heading.

· While the object is rotating, the text on the Rotate button will change to Stop.
Rotation may be stopped at any time by clicking Stop.

Rotation Control 

o Includes an entry box (default value of 0 degrees), as well as counter-clockwise and clockwise
rotation buttons.

o To rotate the selected object:
1. Enter an amount (in degrees) to rotate the object.

· If a value of 0 is used, no limit will be placed on the rotation (the object will
continue to rotate until it is manually stopped).

2. Click either the Counter-Clockwise button or the Clockwise button to begin rotating the
object.

· While the object is rotating, the entry box will display the number of degrees
remaining.

· Rotation may be stopped at any time by clicking the same directional button that
started the rotation.

Depth/Length Control

o Depending on the type of object selected, the depth/length control may have slightly different
options:

§ Configuration 1: 

· Includes an entry box (default value of 0 meters), as well as In and Out buttons.
o The In button moves the object closer to the ocean surface (or shortens a

tether/umbilical).
o The Out button moves the object farther from the ocean surface (or

extends a tether/umbilical).

· To modify the depth/length of the selected object:
1. Enter an amount (in meters) to modify the depth/length.

§ If a value of 0 is used, no limit will be placed on the movement (the
object will continue to move until it is manually stopped, or until it
reaches its minimum or maximum depth/length).

2. Click either the In or the Out button to begin moving the object.
§ While the object is in motion, the entry box will display the

distance/length remaining.
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§ Motion may be stopped at any time by clicking the same
directional button that started the motion.

§ Configuration 2: 

· Includes In, Out, and Stop buttons.
o The In button moves the object closer to the ocean surface (or shortens a

tether/umbilical).
o The Out button moves the object farther from the ocean surface (or

extends a tether/umbilical).
o The Stop button immediately stops movement.

· To modify the depth/length of the selected object:
1. Click either the In or the Out button to begin moving the object.

§ Motion may be stopped at any time by clicking the Stop button.
§ There is no limit on the movement (the object will continue to

move until it is manually stopped, or until it reaches its minimum
or maximum depth/length).

Speed 

o A slider that modifies the speed of movement and rotation of the selected object.
o It acts as a scale, where the full-left position indicates minimum (0%) of the predefined speed of

motion/rotation, and full-right position indicates the maximum (100%) of the predefined speed of
motion/rotation.

Follow

o The Follow button turns on the function of following another object, as predefined in the simulation.

§ This is generally used on a ship to have it follow the ROV.
o When the Follow function is enabled, it may be disabled by clicking the Follow button again.
o This button may be inactive if:

§ The selected object has not been preassigned an object to follow.
§ The Follow function has been designated as always on for the currently running scenario,

which does not allow it to be disabled.

The Ocean Environment settings allow the user to choose specific environmental conditions (above or below
the ocean surface) to mimic a real-world scenario, or to adjust the difficulty of the task(s) required.
These settings can be modified before a scenario is started or in real-time during the simulation:

Time of Day

o A slider, which changes the time of day, and consequentially, the lighting of the selected Scenario.

Fog

o A slider, which changes the fog cover of the selected Scenario as a percentage.

Rain

o A slider, which changes the amount of rain in the selected Scenario as a percentage.
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Water Visibility

o A percentage of visual clarity for virtual cameras (excluding the Aerial and Map views).

§ 0% presents an environment with the maximum amount of suspended particles.
§ 100% presents a virtually perfect view of the undersea environment through the cameras.

Sonar Noise

o Relative amount of acoustic noise that appears on the VSonar display.

§ 0% represents no sonar noise.
§ 100% represents a maximum amount of sonar noise.

Beaufort

o Sea state, as indicated by the Beaufort scale.
o The simulated environment accounts for Beaufort numbers up to 6.

§ 0 - Calm (wave height 0m).
§ 1 - Light Air (wave height 0m - 0.2m).
§ 2 - Light Breeze (wave height 0.2m - 0.5m).
§ 3 - Gentle Breeze (wave height 0.5m - 1m).
§ 4 - Moderate Breeze (wave height 1m - 2m).
§ 5 - Fresh Breeze (wave height 2m - 3m).
§ 6 - Strong Breeze (wave height 3m - 4m).

o This option is not visible if the simulated environment for the selected scenario has no Beaufort
available (wave height of 0m).

Current Speed

o Speed, in knots, of the ocean current.
o The simulated environment accounts for current speeds up to 2 knots.
o This option is not visible if the simulated environment for the selected scenario has a specified

constant current.

Current Direction

o Direction, in degrees, of the ocean current.

§ 0° indicates North
§ 90° indicates East
§ 180° indicates South
§ 270° indicates West

o This option is not visible if the simulated environment for the selected scenario has a specified
constant current.

2.2.4 Controls Menu

The Controls Menu contains an option for toggling controls between USB joysticks and defined plugins (ex:
VROVComms).

Note that controls may not be toggled while in Simulator mode.
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2.2.5 Edit Menu

The Edit Menu contains functions for modifying parameters of the Aerial camera. Selecting Aerial Camera will
open the Aerial Camera Settings Dialog.

2.2.6 Simulator Menu

The Simulator Menu provides functions for updating the full Simulator with modifications made to the scenarios
in the iDEA-DT.

Update

o Updates and adds files from the iDEA-DT to Simulator modules.

Clean

o Removes files from the Simulator modules that are not in the iDEA-DT module.

2.2.7 Help Menu

The Help Menu displays options to open the iDEA-DT Manual (this document) or view the About information,
including links for online support, general information about GRi, or VROV licensing.
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2.3 Tool Ribbon

The Tool Ribbon contains tools for creating and modifying scenarios. The contents of the Tool Ribbon may
vary depending on the element selected in the Viewport or Explorer.

The left-hand side of the Tool Ribbon displays a selection of tools for scenario creation and editing, including
the Select ( ), Measure ( ), Move ( ), and Line ( ) Tools.

o See descriptions of these tools in the following sections.

Following the tool buttons, there is set of tools for scenario and log file recording and playback. These items are
described here.

Next, in Editor mode only, there are a series of information and editing boxes and tools relevant to the currently
selected object/element. This section is described here.

The right-hand side of the Tool Ribbon displays a collection of buttons to show/hide specific UI elements,
including the Explorer ( ), Info ( ), Asset Library ( ), Properties ( ), Browser ( ), and Aerial Camera
Settings ( ).

o See descriptions of these elements in the following sections.

2.3.1 Select Tool

The Select Tool allows the user to select objects in the scenario. Double-clicking an object in the Viewport
while this tool is active will focus the Aerial and Map cameras to that object. This tool is enabled by default
when a scenario is loaded.

2.3.2 Measure Tool

The Measure Tool allows the user to measure the distance between any two points of geometry in the currently
loaded scenario. When enabled, the first mouse click on a piece of 3D geometry will define the first point, and
the second click will define the second point. The two points are connected by a thick red line in the Viewport.

By default, the terrain is not selectable as a point of measurement. This is to allow the user to reposition and
reorient the camera without accidentally clicking on the terrain. To use the terrain for a measurement point, hold
the Ctrl button while clicking the terrain. 

In the Aerial view, the center of the thick red connecting line displays the length in 3D space (accounting for X,
Y, and Z axes). There are 2 additional lines displayed that indicate the horizontal (X and Y axes) and vertical (Z
axis) distances between the points.
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In the Map view, the center of the thick red connecting line displays the horizontal length (accounting for X and Y
axes) between the points. There are 2 additional lines displayed that indicate the X and Y distances individually.

2.3.3 Move Tool

The Move Tool allows the user to change the position of any object in the scenario. Selecting an object in the
Viewport while the Move Tool is enabled will show the XYZ Translate Gizmo and outline the object. Users may
click and drag an object to move it laterally or click and drag the Translate Gizmo to restrict movement along
the selected axis. The Coordinate System Toggle defines whether the object is moved in relation to the default
scenario X,Y,Z axis or the X,Y,Z orientation of the selected object.

Before they can be moved, objects must be unlocked by clearing the Lock on the Tool Ribbon. Objects may be
locked again using the button on the Tool Ribbon or by saving the scenario either from the File Menu or by



   

iDEA-DT User Manual 21

pressing <Ctrl+S> on the keyboard.

While using the Move Tool, the terrain is semi-transparent to aid in cases where part or all of an object is
located below the terrain – occasionally, when importing GIS files that are linked to equipment models, the
models are imported to positions below the terrain.

Alternative to using the Move Tool, positions may be edited using the text boxes on the Tool Ribbon.

2.3.4 Rotate Tool

The Rotate Tool allows the user to change the orientation of any object in the scenario. Selecting an object in
the Viewport while the Rotate Tool is enabled will show the XYZ Rotate Gizmo and outline the object. Users
may click and drag the Rotate Gizmo to rotate the object around the selected axis. The Coordinate System
Toggle defines whether the object is rotated in relation to the default scenario X,Y,Z axis or the X,Y,Z orientation
of the selected object.

Before they can be rotated, objects must be unlocked by clearing the Lock on the Tool Ribbon. Objects may
be locked again using the button on the Tool Ribbon or by saving the scenario either from the File Menu or by
pressing <Ctrl+S> on the keyboard.
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Alternative to using the Rotate Tool, orientations may be edited using the text boxes on the Tool Ribbon.

2.3.5 Line Tool

The Line Tool allows the user to create a 3D line shape in the virtual environment. This tool is only available in
Editor mode.

Selecting the Line Tool changes the Properties Panel to display options for creating new lines. Once activated,
the tool is immediately available to create lines in the Aerial or Map views. Detailed instructions for line creation
can be viewed here.

Line Type

o The Line Type dropdown displays a list of available preexisting line types.

o The  (Add Line Type button) is used to create new line types with individual specified
properties.
§ Clicking the  button opens a dialog to provide a name for a new line type.
§ After the name for the new line type is entered, it is automatically selected in the Line

Type dropdown and its properties are displayed.

· Note that the Properties panel will appear unchanged when first creating the new
line type. This is because the new line type takes on all the properties of the type
currently selected in the Line Type dropdown.

§ The type for any line may be changed after the line has been created.
o The  (Remove Line Type button) is used to remove line types.

§ Note that removing a line type will affect all scenarios that include a line of that type.

Radius

o Visual radius of the line.
o Measured in meters.
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Node Scale

o Defines the size of the nodes (spheres at each point in the line used as handles when editing the
line).

o The size is defined as a scale in proportion to the radius of the line.

§ Node Scale of 1 produces spheres the same radius as the cable.

Z Offset

o Vertical distance (in meters) to offset the Line from the terrain when it is created.

§ When a value of 0 is used, the Line is created with the center point of its cross-section at
the level of the terrain (half of the line is above the terrain and half below).

o Using a value equal to the radius would set the Line directly on top of the terrain.

§ Typically, it is recommended to use a value between 0 and the radius (closer to the radius).
This would put the Line mostly on top of the terrain but suggest some sinking in or
sediment buildup at the base of the Line.

Color

o Displays a color picker in the form of both a color wheel/swatch selection and custom color
definitions using RGB (Red, Green, Blue) or HSL (Hue, Saturation, Luminance).

o If the selected type has a texture defined, the Color swatch will be white.

Visual Parameters

o The visual parameters of the material on the Line.

§ Diffuse

· Amount of color to apply from the defined color of the cable.

· Values range from 0 to 1.
o 0 - The Line appears black (no light reflected), regardless of the color or

texture defined.
o 1 - The color defined is fully visible.

§ Specular

· Amount of specularity (shininess) of the cable.

· Values range from 0 to 1.
o 0 - No specular highlight.
o 1 - Brightest specular highlight.

§ Shininess

· Sharpness of specular highlight on the cable.

· Values range from 0 to 1.
o 0 - Flat, washed out highlight.
o 1 - Round, sharp, nearly pinpoint highlight.

Surface

o Assigns a dynamic surface to the Line, which determines the physical properties of the surface
when interacting with other objects.

Length

o Displays the length of the currently selected Line (or line in progress).
o Note that the length of the Line updates when activating/deactivating the Use Spline checkbox and

by making end connections using the red spheres at the end of the Lines.
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Min Radius

o Displays the minimum radius of the currently selected Line (or line in progress).
o Note that this display is inactive if the Use Spline checkbox is inactive.

Use Spline

o Specifies the visual smoothness of the currently selected Line (or line in progress).
o When this checkbox is inactive, the Line has straight segments with sharp corners.
o When this checkbox is activated, the Line is a continuous curve.
o This checkbox may be activated before, during, or after Line creation.

2.3.6 Scenario and Replay Tools

The scenario and replay tools are used for log file recording and playback, as well as video recording and some 
Mode switching operations.

Record Start/Stop Button ( / )

o This button has two modes - Log file and Video. The mode is determined by the Mode or the
dropdown next to the button.
§ Log file recording is available in Simulator mode only.
§ Video recording is available in all modes.

o Prior to beginning a recording, the button is displayed as  (Start Recording Video) or 
(Start Recording Log File).
§ Begins recording the scenario in progress.
§ Before the recording commences, a file name will be requested. The default file name

provided is the current date and time.
o While a recording is in progress, the button is displayed as  (Stop Recording Video) or 

(Stop Recording Log File).
§ Stops the recording in progress.

o The dropdown next to the record button displays the following options:

§ Record to Log File and Record to Video File

· Determines whether the Record Start/Stop Button produces a log file or a video.
o These menu items are dependent on each other, where the activation

check (ü) may only be next one or the other. Activating one disables the
other.

· These options are not visible in Editor and Player modes since it is not possible to
capture a log file in these modes. Therefore, the button automatically switches to
video mode.

§ Record Interface

· Determines which user interface elements are recorded when recording a video.
o When enabled, the recorded video includes the Viewport, as well as the

Tool Ribbon, Explorer, Info popup, Asset Library, Properties Panel,
Browser, ICC Command Dialog, and mouse pointer.

o When disabled, the recorded video includes the Viewport only.

§ Open Video Folder

· Opens the Windows Explorer to the location of saved videos.

Play/Pause Button  ( / )

o This button has different functions, depending on the currently selected Mode:

§ In Editor mode, the button switches to Simulator mode.
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· In this mode, only Play ( ) is available - Pause ( ) will not be displayed..

§ In Simulator, Player (with a log file selected), and Visualization modes, the button begins/
pauses the currently selected scenario's simulation/log file/visualization.

Stop Button ( )

o This button has different functions, depending on the currently selected Mode:

§ In Simulator mode (with dynamic simulation running), the button switches to Editor mode.
§ In Simulator and Player modes (with a log file selected), the button stops the currently

running simulation/log file and returns the Time Slider to the start position..

Seek Buttons - Reverse ( ) / Fast Forward ( )

o These buttons are active only in Simulator and Player modes with a log file selected.

§  If no log file is selected, the buttons are still visible, but inactive (greyed out) in these
modes.

o When the Fast Forward ( ) button is activated, the log file plays at 2x speed.
o When the Reverse ( ) button is activated, the log file plays in reverse at 2x speed.

Log File Dropdown

o The Dropdown List is visible only in Simulator and Player modes.
o In Simulator mode, the default option is Simulation, which enables the simulation physics, allowing

any dynamic objects in the scenario to move and interact with the environment in a realistic
manner.
§ If log files exist for the currently loaded scenario, those log files will populate the drop down

list below Simulation.
o In Player mode, the default option is Default, which sets the currently loaded scenario to its initial

static loading state.
§ If log files exist for the currently loaded scenario, those log files will populate the drop down

list below Default.

Time 

o The Time indication area consists of a numerical time value (0:00:00), representing
hours:minutes:seconds, as well as a time slider with Time Position Indicator ( ).

o In Simulator mode with dynamic simulation running, the numerical time value indicates the amount
of time from when the dynamics/physics were started.

o In Player mode with a log file selected, the numerical time value indicates the current position of
the Time Position Indicator.
§ This value may not begin at 0:00:00 if the recording did not begin at that time.

o The Time Position Indicator displays the current position between the beginning and end of the
recorded log file.

2.3.7 Information and Editing Tools

In Editor mode, the following items are displayed in the Tool Ribbon to aid in editing scenarios.

Positional and Rotational Information

o This set of entry boxes and buttons offers information about the currently selected object/element,
including X, Y, and Z positional and rotational data.

o When an object is selected, its current position and rotation are displayed in text boxes.

§ When the object is locked (either manually or after loading a scenario), these boxes are
used for display only. The values may not be edited.
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§ When the object is unlocked, new values may be entered in the boxes. The new value is
applied after pressing Enter.

§ If the Coordinate System Toggle is set to Local, then the values in the boxes will be all
zeros. New values may be entered in the boxes, which are applied after pressing Enter.

o Objects may be moved or rotated using the axis labels for the position and rotation boxes.

Coordinate System Toggle ( / )

o This button specifies the orientation in which an object may be edited using the position and
rotation boxes, Move Tool, or Rotate Tool.

o Global Coordinates ( )

§ By default, objects are moved and rotated in the Global Coordinate System, meaning the
default scenario X,Y,Z orientations.

o Local Coordinates ( )

§ When activated, objects are moved and rotated in the Local Coordinate System, meaning it
uses the X,Y,Z orientation of the selected object.

§ When activated, the values in the position and rotation boxes are all zeros. New values
may be entered in the boxes, which are applied after pressing Enter.

Lock/Unlock Button ( / )

o This button toggles whether the selected object is fixed in place or movable.

§ Existing scenario objects are locked on scenario load.
§ New objects are unlocked when first added to the scenario.
§ Unlocked objects are automatically locked by saving the scenario.

2.3.8 Explorer

The Explorer displays a categorical list of all items included in the currently loaded scenario. It may be enabled
from the icon in the Tool Ribbon ( ) or from the View Menu. This dialog is docked to the left side of the
Viewport by default, but may be pulled away using its title bar and docked to the right side. 

The Explorer can be used to select the different elements of the scenario. Object types and menus are
searchable through the search box, located at the top of the Explorer, immediately to the left of the Explorer
icon ( ). Additional properties of objects are editable by clicking them in the Explorer.

Most elements have right-click menus that enable different functions for that type:
o Right-clicking the Terrain in the Explorer provides an options to Show Properties (open the

Properties Panel, if not already open), which contains settings to customize the appearance of the
terrain.

o Right-clicking on a Platform, Static, or Moveable Object in the Explorer provides options to Show
Properties (open the Properties Panel, if not already open), Add (or Edit) Info Tag, Rename, Group,
View Attributes (GIS attributes related to the object, if GIS data exists in the scenario with links to
the selected object), Link File, and Link URL to the object for data management purposes.

o Right-clicking a Line Object in the Explorer provides options to Add (or Edit) Info Tag or View
Attributes (GIS attributes related to the line, if applicable).

o Right-clicking a Jumper Object in the Explorer provides options to Add (or Edit) Info Tag, Group,
or Rename the jumper.

o Right-clicking a GIS geodatabase in the Explorer provides options to Lock to Objects (toggles the
locking of any GIS data symbols to their respective 3D objects so they can be moved together or
independently), Export (exports the GIS file reflecting any changes that have been made to the data
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within the iDEA-DT application), Show All, and Hide All (show or hide all the layers of the selected
geodatabase).

o Right-clicking the Terrain in the Explorer provides options to Rename, Color, Add Group, and Add
(or Edit) Info Tag. Group creation and editing is described here.

2.3.9 Info

Enabling the Info display opens a pop-up window in the Viewport attached to the currently selected object or
element. The Info pop-up displays the name of the object and InfoTag (if assigned) in the title of the pop-up. The
expanded lower section of the pop-up includes Location (X and Y position), Depth, Heading, Links, and Files.

2.3.10 Asset Library

The Asset Library displays a selection of items that may be added to the currently loaded scenario. It may be
enabled from the icon in the Tool Ribbon ( ) or from the View Menu. This dialog box is docked to the right side
of the Viewport by default, but may be pulled away using its title bar and docked to the left side. The dialog may
be expanded from a single column to any number up to 5 columns by click-dragging the edge of the dialog.
Items within the Asset Library are categorized by type. Each category may be collapsed or expanded to hide/
show all items within that category.

To include items from the Asset Library in the currently loaded scenario, either:
1. Double-click the asset to add it directly in front of the current camera view.
or
2. Drag and drop the asset into the Viewport.

o Note that when any item is added from the Asset Library, the Move Tool is automatically activated,
allowing the user to immediately position the object as desired, including attaching it to other
objects in the scenario using Snap Points.

After a model has been added to the scenario, its position and orientation can be modified using the Move Tool
and Rotate Tool. The user may also input precise coordinates and set orientation values in the text entry boxes
on the Tool Ribbon.

2.3.10.1 Snap Points

Many equipment objects have predefined connection points, or Snap Points, which allow the object to be
interfaced or connected with other equipment objects. When the Move Tool is enabled and an object is selected
and unlocked, the possible Snap Point connections on other objects are highlighted with green spheres.
Dragging the selected object onto one of these snap points will automatically snap the object to the predefined
position and orientation to complete the connection. Snap Points may also be used to define connection
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positions and orientations for lines.

After objects have been snapped together, the full assembly can be moved by selecting and moving the parent
object. For example, if the user adds a wellhead, and then snaps a horizontal tree to the wellhead, then moving
the wellhead will also move the horizontal tree.

2.3.11 Properties Panel

The Properties panel displays a selection of information and editable parameters for the currently selected
element. This panel is docked to the right side of the application window by default, but can be pulled away
using its title bar and docked to any other side of the window.

This panel may be enabled from the icon in the Tool Ribbon ( ), from the View Menu, or by right-clicking
specific simulated elements in the Explorer and choosing Show Properties.

The panel header includes the title, an options button, and a close button.
o The title of the Properties panel describes the type of element for which properties are displayed

(object, terrain, etc.) and provides the name of the element.
§ When creating a new scenario, the terrain is the default selection.

o The Properties Lock  button ( / ) provides the user with an option to lock the panel contents to
the current selection.

o The purpose of this is to prevent the panel contents from changing in the
event of selecting a different object/element in the Viewport or Explorer
while still intending to edit the previously selected object/element.

o The Properties Close button ( ) closes/hides the Properties panel.

2.3.12 Browser

Enabling the Browser opens a new panel with an embedded internet browser. It may be enabled from the icon
in the Tool Ribbon ( ) or from the View Menu. This panel is docked to the right side of the application window
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by default, but can be pulled away using its title bar and docked to any other side of the window.

If the selected object has a URL attached, that URL will be displayed in the Browser. If no URL is defined for the
selection, the URL defined for the scenario will be displayed. If no URL is defined for the scenario, then the
Browser window will appear blank.

2.3.13 Aerial Camera Settings

The Aerial Camera Settings dialog contains options for the controls, movement, and viewing distance of the
Aerial camera. It may be enabled from the icon in the Tool Ribbon ( ) or from the Edit Menu.

§ View Distance

· Sets the maximum visible distance (in meters) in the Aerial view.

§ Monitor Gamma

· Modifies the brightness of the Aerial View camera to accommodate different
hardware specifications.

§ Camera Control

· Invert Unlocked Rotation reverses Aerial camera rotation with the mouse when not
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locked to any object.

· Invert Locked Rotation reverses Aerial camera rotation around an object with the
mouse when locked to that object.

· Zoom Speed changes the speed of Aerial camera movement when zooming using
the mouse scroll wheel.

o Default displays the selected Zoom Speed when no modifier key is used.
o Modified (Shift) provides a second option for Zoom Speed, which is used

when holding down the Shift key.

· Pan Speed changes the speed of Aerial camera movement when panning using
the middle mouse button or WASD keys.

o Default displays the selected Pan Speed when no modifier key is used.
o Modified (Shift) provides a second option for Pan Speed, which is used

when holding down the Shift key.

· Rotate Speed changes the speed of Aerial camera movement when rotating using
the left mouse button.

o Default displays the selected Rotate Speed when no modifier key is used.
o Modified (Shift) provides a second option for Rotate Speed, which is used

when holding down the Shift key.
§ Automatic Camera

· The dropdown box provides options for different smoothing algorithms for the
smoothness of the Auto Camera movements.

· Translate Smoothing changes how closely the Auto Camera position matches that
of the object it is following.

· Rotate Smoothing changes how closely the Auto Camera rotation/orientation
matches that of the object it is following.
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2.4 Viewport

The Viewport presents a visual display of the currently running scenario or log file.

Most viewport selections such as ROV cameras and sonars are constrained to objects and are not adjustable,
except by moving the objects to which they are attached. Exceptions to this include the Aerial, Map and NAV
views, which may be adjusted using the mouse.

Viewport/Camera Settings Menu

o The currently selected camera/sonar is displayed in the top-left corner of the Viewport.

§ If these are not visible, hovering the mouse in the top-left corner of the Viewport will make it
appear.

o Clicking the current camera/sonar name with the left or right mouse button will display a dropdown
with:
§ All available cameras and sonars.

· The right and left arrow keys on the keyboard may also be used to cycle through
available cameras/sonars.

§ Options to Add or Remove cameras/sonars to the cycle (when using arrow keys or
multiple viewports).

· Added cameras appear after the camera view in which the option was selected.

§ Options to change the configuration of the Viewports when multiple viewports are activated
using the Screen Settings Menu in the top-right corner of the Viewport or by pressing the
F5 key.

· The configuration of multiple viewports (positions of each viewport) may be modified
using the Use Vertical Split option. This defines the primary split as being either
horizontal (default) or vertical when adding viewports.

· When multiple viewports are visible, they may be resized using the mouse by
dragging the viewport boundaries to the desired positions.

o Each viewport has a camera/sonar name in the top-left corner, which may
be used to select the camera view for that viewport.

· The user may Save Settings for multiple viewports so they load automatically on
the next scenario startup.

o The saved configuration is loaded for any scenario that uses the same
combination of vehicles.

o The user may Restore Defaults to revert the Viewport settings to the
initial layout, ignoring any modifications.

§ Options to change the Lighting in the Aerial View.

· Global lighting is the default selection with the ambient Aerial View lighting
activated.

· Viewer lighting is similar to Global lighting, but without the Global Lighting or
Global Shadows enabled.

· Scene lighting uses no ambient lighting at all, and is lit using only the lights
defined in the scenario.

§ Options to modify the visual appearance of the Selection in the Viewport.

· Show Outline toggles the visibility of the object outline.

· Isolate modifies visibility of objects in the scenario such that the selected
object(s) remain completely visible, while all other objects become semi-
transparent.

o This mode remains active, even while changing the selected object(s),
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until deactivated from this menu.

· Isolate Options opens a dialog with ways to modify the appearance of objects and
the environment around the selected object(s).

o The color selector and the Use Color checkbox hides all objects excluding
the selected object(s) and changes the background to the selected color.

o The Opacity slider changes the opacity of all objects excluding the
selected object(s).
§ Note that this slider is overridden by the color selector (if a color is

used, all other objects are hidden).

· Single Click toggles behaviour of the Select Tool in the Viewport.
o When inactive (default), single-clicking on an object does not change the

current selection in the Viewport, Explorer, or Properties Panel. A double-
click is required to change selection.

o When activated, single-clicking on an object changes the current selection
in the Viewport (shows the object outline, if enabled), Explorer, and
Properties Panel.
§ Note that a double-click is still required to change the object to

which the camera is locked.
§ Option to Show Group Colors.

· Switches the visible color of any objects included in a Group to the Group color.

· This menu option is only available when there is at least one Group included in the
scenario with a color assigned.

· This may also be activated using the F1 key.

§ Options to Save Aerial View positions.

· Clicking Save Aerial View will display a dialog to name the saved position and
orientation. 

· Note that this does not create an additional Aerial View camera, but a defined
position to which the Aerial camera may be moved.

· The saved Aerial View position is then selectable in the Select Aerial View list
unless it is removed using the Remove Aerial View option.

· The scenario must be saved in order to permanently include the added Aerial
Views in the scenario file. Otherwise, they will be available only until the scenario
is ended.

Object Selection Menu

o The currently (or most recently) selected object is displayed in the top-left corner of the Viewport
next to the camera/sonar selection.
§ If it is not visible, hovering the mouse in the top-left corner of the Viewport will make it

appear.
§ This menu is only available in the Aerial View.

o Clicking the object name with the left or right mouse button will display a list of selectable objects
in the scenario and the option to lock the camera in relation to the selected object.
§ Lock constrains the position of the camera to that of the selected object, regardless of

orientation. 
§ Follow constrains both the position and orientation of the camera to that of the selected

object.
§ Auto constrains the position of the camera to that of the selected object and orientates the

camera to the object orientation (similar to Follow) but has a list of preset camera angles
(Auto Camera View) and definable smoothing options to customize movement of the
automatic camera.

o Below the camera constraint options, there are categories for all the objects in the scenario.
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Hovering the mouse over any of the categories will expand to show the objects included in the
category.

Screen Settings Menu

o Options to modify the Viewport(s) on the selected screen are displayed in the top-right corner of the
Viewport, including:
§ Add Viewport

· The leftmost button adds a viewport to the current screen up to a maximum of 4.

· The button is displayed differently, depending on the current number of active

viewports on the screen and vertical split screen option ( , , , , ,

or ). 

o The button graphic indicates the viewport configuration for the current
screen after the button is clicked. For example, if there is currently one

viewport visible, the button is displayed as  or  to indicate that

clicking the button will split into two views.
o Each viewport has a camera/sonar name in the top-left corner, which may

be used to select the camera view for that viewport.

· When screens are added, this button is available at the top-right corner of each
screen as well.

o Viewports may also be added using the F5 key.
o To add viewports to the second screen using F5, that screen must first be

activated by clicking on it with the mouse.
o When 4 viewports are displayed, clicking this button will set the screen

back to 1 viewport.

· When multiple viewports are visible, they may be resized using the mouse by
dragging the viewport boundaries to the desired positions.

§ Fullscreen

· The center button hides the currently displayed menus and toolbars, expanding the
viewport(s) on the first screen to cover the entire area of the screen

o This button is only available on the first screen, as each additional screen
is always in fullscreen mode.

· The button is displayed as  when not in fullscreen mode (default) and as 
when in fullscreen mode.

· Fullscreen mode may also be activated/deactivated using the Enter key.

§ Add Screen

· Adds a viewport on the next available screen/display.
o When additional screens are activated on all available displays, clicking

this button will deactivate the additional displays.
o This button is only available when multiple displays are connected.
o Additional screens may also be added/removed using the F9 key.

· The button is displayed as .

2.4.1 Aerial View

The Aerial View is the default camera displayed in the Viewport.
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It is an adjustable camera that may be freely movable, or centered on an object. Double-clicking on any object
in the scenario (excluding the terrain and ocean surface, as well as any tether, umbilical, or cable) makes that
object the center of focus/rotation.

The position and orientation of the Aerial View can be modified using the mouse:
o Holding down the left mouse button while moving the mouse will change the orientation of the

camera.
o Holding down the right mouse button while moving the mouse will zoom in or out in the current view.

§ Using the mouse scroll wheel will also zoom in and out.
o Holding down the middle mouse button (scroll wheel) while moving the mouse will change the

position of (or pan) the camera.
§ If the user pans the camera, it becomes freely movable, and is no longer locked to any

object.

2.4.2 Map / NAV Views

The Map View and NAV View are orthographic top-down camera views of the running scenario/log file.

These views are freely movable using the mouse. The position of the Map View or NAV View can be modified
using the mouse:

o Holding down the left mouse button while moving the mouse will change the position of (or pan) the
camera.

o Using the mouse scroll wheel will zoom in or out in the current view.

Clicking the right mouse button will display an option to switch to the Aerial View, which will be located at the
position in the scenario where the mouse is clicked.

The Map view is not included by default in the camera cycle (using arrow keys or multiple viewports), but may
be added by clicking the name of the current camera in the top-left corner of the viewport and choosing Add >
Map from the menu. It will appear after the camera view in which the option was selected.
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Map View

o Has ambient lighting, and is not affected by scene (ROV) lights.
o Displays all objects, terrain, tethers, umbilicals, cable, etc.

§ Does not display ocean surface.
o Double-clicking on any object in the scenario (excluding the terrain, as well as any tether,

umbilical, or cable) temporarily makes that object the center of focus.
§ The center of the screen stays in the selected object's position (does not follow the object

if moved).

NAV View

o Displays all objects' associated DWFs as opposed to the simulated objects/models.

§ Does not display ocean surface or terrain.
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2.4.3 Objective Overlay

The Objective Overlay is a tool that helps guide and evaluate independent learning. It is a central application of
the VROV system that describes mission instructions and completion status as the user progresses through a
mission. This progressive instruction ensures that training points are completed in a specific order, allowing
students to self-monitor training, without the need for constant supervision.

It is displayed during training in the top-right corner of the screen, with options to display the Last Completed,
Current, and Next objectives or to display only the Current objective. It is only available in Editor, Simulator, and
Player modes.

After all objectives have been completed, the Objective Overlay displays a Mission Complete message. The
user may then Save Summary Report in the ICC Command Dialog, which displays:

o Scenario information (Time, Date, Pilot ID, Environmental Conditions )

o Objective List

o Completion Verification with Time Stamps

o Level of Difficulty 
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o Pilot and Supervisor Verification 

Summary Reports are saved in secure PDF format and cannot be altered by the student. They can be reviewed
and compared against other pilots to compare strengths/weaknesses, and the best pilot for a particular mission.



   

iDEA-DT User Manual 38

2.5 Status Bar

The Status Bar displays information about the status of the currently selected element, including its name,
position and orientation. It also displays the currently selected camera view and the camera's current position in
3D space. It may be enabled from the View Menu

If the selected view is the Map view, instead of camera position, the position displayed is the Easting and
Northing (X and Y) coordinates of the mouse pointer, and the height or depth (Z) of the terrain at that location.

If the selected object is a line, the Status Bar will display the line's length and minimum bending radius. When
in Map view, the Status Bar will show the Easting and Northing (X and Y) coordinates of the mouse pointer, and
the height or depth (Z) of the terrain at that location.

Aerial View with Object selected:

Map View with Line selected:
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3 How to / Tutorials

The following item detail the steps involved in the most common uses for the iDEA-DT:

1. Import a Terrain

2. Create / Edit a Scenario

3. Create / Edit a Line

4. Create / Edit a Jumper

5. Create / Edit a Group

6. Working with GIS Data
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3.1 Import a Terrain

Terrain files (XYZ or TXT format) may be imported and converted to GRi's proprietary terrain format. The terrain
may then be used .

Import a Terrain

1. Open the iDEA-DT software
2. Select File > Import Terrain from the MenuBar.
3. Browse to the directory containing the terrain file (XYZ or TXT format). Select the file and click

Open. After the terrain file is selected for import, the user will see the Terrain Import Progress
dialog.

4. When the data import is complete, the user will see some basic details and can select the units of
measurement for the imported data (as shown below). Selecting Save will allow the user to name
and save the newly imported terrain.
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5. When complete, the new terrain will be included in the list of available terrain files in the Terrain
Selection dialog.
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3.2 Create / Edit a Scenario

Scenarios may be created and/or edited using the iDEA-DT in Editor mode.

Create a New Scenario

1. Open the iDEA-DT software.
2. Select File > New from the MenuBar to open the Select Terrain dialog.
3. Choose an existing terrain from the dropdown and click OK to start a new scenario with the

selected terrain in Editor mode.
4. Objects can be added to the scenario from the Asset Library. From the library, either double-click

the desired object or drag it from the library into the Viewport
5. When the scenario is complete, save it by selecting File > Save Scenario or File > Save

Scenario As.
§ Please see notes on scenario names.
§ Note that it is recommended to always use a different name from any of the existing

content so there is no confusion between that and any custom content.
6. To start dynamic simulation, select Mode > Simulator from the MenuBar.

Edit an Existing Scenario

1. Open the iDEA-DT software.
2. Select File > Open Scenario from the MenuBar to open the Select Scenario dialog.
3. Choose a scenario from the dropdown and click OK to start the scenario in Editor mode.
4. To modify the scenario, select Mode > Editor from the MenuBar, then use the Tool Ribbon and/or

Asset Library to edit the scenario. 
§ Save modifications by selecting File > Save Scenario As.

· Please see notes on scenario names.

· Note that it is recommended to always use a different name from any of the
existing content so there is no confusion between existing and custom content.

5. To start dynamic simulation, select Mode > Simulator from the MenuBar.

Copy Scenario(s) to VROV Simulator (if applicable)

1. Open the iDEA-DT software.
2. Select Simulator > Update from the MenuBar.

General notes on scenario names:

· Scenarios are typically named with the syntax ScenarioName_VehicleName.
o This formatting automatically fills the ICC Controls scenario selection dialog, where the 

VehicleName parameter becomes an option in the Vehicle dropdown and the ScenarioName fills
the Scenario dropdown.
§ The ScenarioName may include spaces if desired, but underscores ( _ ) will cause it to

separate into the fields of the ICC Controls scenario selection dialog.
§ This is not applicable when loading scenarios from the File menu in the iDEA-DT since the

full name of the scenario is displayed.
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3.3 Create / Edit a Line

Lines may be created and/or edited using the Line Tool in iDEA-DT in Editor mode.These are used as
representations of pipelines, flow lines, umbilicals, flying leads, flexible risers, etc. in the scenario.

Create a New Line

o Lines may be created in the Map View (preferred) or in the Aerial camera.
1. Open the iDEA-DT software and start scenario (or create a new scenario) in Editor mode.
2. Determine the view (Map or Aerial) and location in the Viewport where the new line will be

created.
3. Select the Line Tool ( ) in the Tool Ribbon.
4. In the Properties Panel, which will automatically open when the Line Tool is selected (if not

previously visible), choose the Line Type from the dropdown.

· The properties of the Line Type are displayed in the Properties Panel upon
selection.

5. Begin creating the line in the Viewport by left-clicking on the terrain. 

· A point is created on the terrain for each clicked position.

· As the line is created the user can remove the last point drawn using Ctrl+Z on the
keyboard.

· The camera may be moved as well as zoomed in/out using the camera keyboard
controls or Viewport mouse controls while the line is being created.

6. When the last point for the line is created, right-click to end the line and show a dialog box
where a name for the line may be entered.

7. Once a line has been created, its end points can be connected to pre-defined line
connection points (Snap Points) on some equipment models. The line's end-point
connectors are defined with red spheres. 

· The user can manipulate these end connectors by clicking them with the mouse
pointer and dragging them to an available connection point. All possible connection
points in the scenario are highlighted with green spheres when a line's end-point
connectors are selected. The curve of the end connection can be adjusted using
the yellow spheres on the two Bezier handles. The user can hold shift while using
the Bezier handles to adjust each side of the curve independently.
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Edit a Line

o Lines may be edited using the Move Tool. With this tool activated, the user may select and unlock
any line in the scenario, then select a point on the line and move it using the translate gizmo.
Alternatively, click-dragging the point itself will move it horizontally (not in the Z-axis). Using this
method sometimes results in some points positioned undesirably below or above the terrain. All
points on a line can be snapped back to the level of the terrain by right-clicking the line name in
the Scenario Explorer and selecting Use Terrain Z. This function does not affect the end connection
curves.

o New points may be added to a line by double-clicking anywhere on the line. 

§ A point may also be removed by selecting it and pressing the Delete key.
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3.4 Create / Edit a Jumper

Jumpers may be created and/or edited using the iDEA-DT in Editor mode.

Create a New Jumper

1. Open the iDEA-DT software and start scenario (or create a new scenario) in Editor mode.
2. From the Asset Library, double-click a jumper type or click and drag it into the scenario.
3. To move the Jumper, activate the Move Tool and click-and-drag one of the end connections to move

that end of the Jumper in the Viewport. Note any predefined destinations (Snap Points) while
moving the Jumper connector. To reposition the entire jumper without connecting to a Snap Point,
either use the Move Tool gizmo or click any place on the jumper that is not a an end connector or
spherical object and it may be dragged around the Viewport with the mouse.

Customizing a Jumper

1. Jumpers may be edited using the predefined green spheres that appear along the Jumper sections
when selected. The green spheres are used to resize/reshape the jumper along its X,Y, and Z axes.
Selecting the end connection points of the Jumper will allow the user to resize the object and move
it around in the Viewport.

1. Selecting the center sphere on the Jumper displays that sphere position in the world in the
Tool Ribbon entry boxes. This sphere may only be moved in the Z-axis using the Move
Tool., as its X and Y coordinates are determined by the shape of the remaining segments
of the Jumper

2. Selecting any of the three spheres near either end of the Jumper (not the sphere at the very
center) changes the Tool Ribbon entry boxes to display dimensions of the straight
sections of the Jumper pipe in meters.

· Default lengths upon creation of a new Jumper are 1, 1, 2.

· The rotation of each jumper end connection may also be edited from the Tool
Ribbon entry boxes using the RZ box. This value does not change the values of the
segments labelled A, B, or C, but will automatically update the central segment as
required.
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Clicking anywhere on the jumper that is not a spherical object while the Move Tool is active will allow the user to
reposition the entire object. 
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3.5 Create / Edit a Group

Groups provide the user with a way to isolate and visualize specific sets of objects. Groups are managed in the
Explorer.

Create a New Group

o Groups may be created using two different methods:
1. Create a new empty Group in the Explorer directly:

1) Open a scenario in Editor mode in the iDEA-DT.
2) Right-click in the empty space below all the element headers in the Scenario

Explorer and choose the Add Group option.
2. Create a Group beginning with one of the objects to be included in the Group:

1) Open a scenario in Editor mode in the iDEA-DT.
2) Expand an object header (ex: Static Objects or Moveable Objects) in the

Scenario Explorer.
3) Right-click an object, and choose Group > Add. 

§ Either of these methods will open the Select Group Name dialog. After entering a name
for the Group, a Groups header will appear in the Scenario Explorer (if not previously
existing), which may be expanded to see all Groups in the scenario.

§ Note that sub-groups may be created by right-clicking on a Group name and choosing
Group > Add Group.

Add Objects to a Group

o Objects may be added to a Group (or sub-group) using any of the following methods:
1. Use the second method of creating a Group, as defined above, and the object will

automatically be included in the created Group.
2. From the object's right-click menu in the Explorer 

1) Expand the object header (ex: Static Objects or Moveable Objects) in the
Scenario Explorer containing the object to be added to a Group.

2) Right-click the object and highlight Group to expand the sub-menu:
o Below the option to Add a new Group and the menu divider, there is a list

of all existing Groups in the scenario.
o By default, objects are not included in a Group, so the Group designation

is None.
3) Select one of the Group names to add the object to a Group.

· Note that this same procedure may be followed for objects already included in a
Group to move the object to a different Group (or remove from all groups by right-
clicking selecting Group > None).

o Once a Group contains at least one object, the Group may be expanded to see all objects
contained within the Group, as well as any sub-groups.

Change the Properties of a Group

o The visual properties of a Group may be modified from the Scenario Explorer:
1. Expand the Groups header in the Scenario Explorer to see all Groups in the scenario.
2. Right-click a Group name and select Color to display the Group Edit dialog.

· In the Group Edit dialog, there are three properties available to modify:
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1. Colors selector
§ Defaults to white.
§ A new color may be selected by clicking any of the swatches in

the Standard tab, by choosing the Select dropper and choosing
any color on the screen, or by clicking the Custom tab to input
exact color values.

2. Use Color checkbox
§ Defaults to inactive (deselected).
§ Activating this checkbox will change the color of all objects in the

selected Group to the defined color

· Note that this display may be activated/deactivated from
the Viewport/Camera Settings Menu or by pressing the F1
key.

· Selecting a new color (other than the default white) will
also automatically activate this checkbox.

3. Opacity slider
§ Defaults to 100%.
§ Changes the opacity/transparency of all objects in the Group.

o Note that sub-groups do not inherit the visual properties of the parent Group, and must be defined
individually for each sub-group.

Remove Objects from a Group

o Objects maybe be removed from a Group (or sub-group) using any of the following methods in the
Scenario Explorer:

1. Delete the Group (see instructions below).
2. In the expanded Group, select the object and press the Delete key.
3. In the expanded Group, right-click the object and highlight Group to expand the sub-menu.
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Then select None to remove the object from all Groups (or select one of the other Group
names to move the object to that Group).

4. In the expanded Group, select the object and drag it into a different group.
5. Expand the object header (ex: Static Objects or Moveable Objects), right-click the object

and highlight Group to expand the sub-menu. Then select None to remove the object from
all Groups (or select one of the other Group names to move the object to that Group).

Delete a Group

o After a Group is added to a scenario, it may be removed using the following steps:
1. Open a scenario in Editor in the iDEA-DT that contains at least one Group.
2. Expand the Groups header to see all Groups in the scenario.
3. Select one of the Groups and press the Delete key on the keyboard.

· Note that deleting a Group does not delete any objects from the scenario. It just
removes any assigned Group designations for the object(s).
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3.6 Working with GIS Data

Some of the more advanced features of the iDEA-DT software are its ability to import, visualize, manipulate and
export GIS data. Currently, the iDEA-DT software only accepts ESRI's format of GIS shapefiles and
geodatabases.

GIS Data Preparation

o Prior to import into iDEA-DT, GIS data should be made ready for 3D editing by ensuring any shape
layers from the geodatabase to be edited in 3D are setup to contain 3D data. A geodatabase can
contain both 2D and 3D layers, but only the 3D layers will retain any edits done in the iDEA-DT
when exported.

o ESRI Geodatabase shape layers can be converted from 2D to 3D, setting all features to sea level
(or Z=0), in ESRI's Arc Catalogue software using the steps below:

1. Start Arc Catalogue, navigate to the geodatabase folder and open the geodatabase to see
the shape layers.

2. Right-click on the layer you want to convert and select Export > To Geodatabase
(single). This will open the Feature Class to Feature Class dialog box.

3. In the Output Location field, navigate to the same geodatabase you are editing.
4. In the Output Feature Class field, enter the name of the new 3D layer you want to create.

We recommend using the same name as the layer you are converting and adding “_3D” at
the end to differentiate it from the 2D version of the layer. (i.e., FAC_GRI_MFLD  => 
FAC_GRI_MFLD_3D)

5. Select the Environments button at the bottom of the dialog box. This will open the
Environment Settings dialog box.

6. Expand the Z Values section of the list, enter 0 in the Default Output Z Value field and
select Enabled from the Output has Z values drop-down menu. Click OK

7. Click OK again to run the conversion. This will create a new 3D layer in the geodatabase.
8. The old 2D layer can now be deleted, leaving only the new 3D layer.
9. Repeat this process for any other layers that need to be edited in 3D in iDEA-DT.

o Note: The method above shows how to convert a shape layer to 3D using a constant. Geodatabase
shape layers can also be converted to 3D using a surface (bathymetry file) or an attribute of the
feature, but these additional data types may not always be available. See ESRI's online
documentation for instructions on how to use these other conversion methods.

GIS Data Import

o Users can import GIS geodatabases into iDEA-DT using the following steps:
1. Open the iDEA-DT software, select File > Open Geodatabase, navigate to the location of

the geodatabase folder, select it and click Select Folder.
2. In the Geodatabase Import dialog box, select the units that the geodatabase uses.
3. There are options to snap all of the data to either the ocean surface (Use Surface Z) or the

seafloor (Use Terrain Z). Select one of these checkboxes if desired. In most cases for
subsea projects, the user will select Use Terrain Z when importing a geodatabase for the
first time. This will bring all of the data down to terrain level, where most of the equipment is
located.

4. Click OK in the Geodatabase Import dialog. This will open the Select Terrain dialog box. 
5. Select the desired terrain from the drop-down menu and click OK. (Users can import XYZ

bathymetry files to create 3D terrains from the File menu – see section 2.2.1)
6. The GIS data and terrain file will load into the 3D viewport. Any 3D models that have been

setup to work with the GIS data will be imported and positioned accordingly. Any 3D line
shapes that have been setup to work with the GIS data will be automatically created.
(GRi's 3D Models can be linked to GIS data by including the model's name in a “Tag_3D”
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field for that feature in the attribute table of the shape layer.) 

Manipulating GIS Data in iDEA-DT

o Once the geodatabase has been imported into iDEA-DT the user can edit the position of any linked
3D models or lines using the Move Tool. The edits to the 3D models and 3D line shapes will be
reflected in the linked GIS data.

o Users can follow the general workflow detailed below to edit their data in iDEA-DT:
1. Hide any geodatabase layers that don't need to be edited. This will clean up the scenario

so only the required working data is visible. This can be done by expanding the
geodatabase in the Geodatabases section of the Scenario Explorer and unchecking the
boxes for any layers the user wants to hide.

2. Move any 3D models for support structures, such as wellheads and suction piles, to their
correct depths or stick-up heights.

3. Move any 3D models for equipment with mud-mats (equipment that sits directly on the
terrain) to the desired depths.

4. Snap 3D models of any equipment that sits on support structures onto the 3D models of
the support structures.

5. Move any surface objects, such as floating platforms and support vessels, up to the ocean
surface.

6. Complete the end-point connections of any 3D lines that need to be connected to
equipment models. 

GIS Data Export

o Once the geodatabase has been edited to the user's satisfaction, it can be exported back out of
iDEA-DT for use in other applications. Follow the steps below to export a geodatabase from iDEA-
DT:

1. Right-click the geodatabase in the Scenario Explorer panel and select Export. This will
open the Select GDB Folder dialog.

2. Use the button to the right of the text box to open the Select Destination Folder dialog.
3. Click the New Folder button at the top, and name the new folder accordingly.
4. Click Select Folder, and then click OK to export the geodatabase to that location.
5. The exported geodatabase can now be loaded into ArcGIS applications, and other GIS

software packages that accept ESRI format GIS data.
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4 Keyboard Commands

Below are keyboard commands for controls in the iDEA-DT:

Keyboard
Command

Description

F1 Activate / Deactivate Group colors display. 

F3 Toggles Aerial camera lock/unlock function.

F5 Cycles multiple camera views.

F6 Toggles Aerial camera global lighting vs scenario lighting.

F7 Toggles AutoLights on/off.

F9 Activates / Deactivates additional view(s) on a second monitor.

Ctrl + C Activates / Deactivates compass.

Enter Toggles Fullscreen on/off.

¬  ® (Arrows) Cycles display of available cameras/sonars.

W, A, S, D Move the Aerial, Map, or NAV cameras forward, left, back, and right
(Holding Shift with any of these keys will enable the "Run" camera
movement. speed setting - View > Aerial Camera Settings).

Q, E Move the Aerial, Map, or NAV cameras up and down (Holding Shift
with any of these keys will enable the "Run" camera movement
speed setting - View > Aerial Camera Settings).

When ICC Controls are Visible (in Simulation Mode)

Keyboard
Command

Description

Ctrl+F Begins, Pauses, or Resumes a scenario/log file physics/playback.

Ctrl+G Stops the current scenario/log file.

Ctrl+H Begins or ends recording of a log file/video. Note that a Profile must
be loaded.

When Joysticks are Connected and Assigned (in Simulation Mode)

Keyboard
Command

Description

Ctrl + J Displays / Hides joystick designations (if applicable).

1 Cycles through items controllable by Joystick 1 (if applicable).

2 Cycles through items controllable by Joystick 2 (if applicable).
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5 Troubleshooting

If you have questions about a topic that is not covered in this document, please visit our web support for
assistance.

Common Errors

If a scenario does not start, or does not perform as expected, it is important to know how to go about debugging
it. Typically, the most useful information is found in the debug.txt file located in the root of the VROV module
folder, typically C:\iDEA-DT_(folderName)\debug.txt . Below is a list of the most common issues:

1. iDEA-DT doesn't start from the desktop icon.
§ Possible Sources of Error:

· Software License.
o If using a physical Hasp dongle for licensing, check that hasp light is on. If

not, try reinstalling the drivers.
o If using a software lock for licensing, the license may be expired. 

· Check for an instance of the module already running. Only one instance may be
running at a time.

· Check that the GPU is not overloaded. For example, connecting four monitors at
2160 resolution will cause the VROV software not to run due to strain on the GPU.

http://grisim.kayako.com/
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